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Interactive Mapping Using Google Earth Pro 

Julie Jones, GIS & Map Librarian and Librarian for Geography, Simon Fraser University  

 

Intro: initial maps to explore 

Gwich'in Place Names and Story Atlas: http://atlas.gwichin.ca/index.html 

Urbanarium Smartmap: http://urbanarium.org/smartmap  

Montréal Sound Map: http://www.montrealsoundmap.com/ 

 

Exploring Google Earth Pro 

The data used for this exercise can be downloaded from this address: http://bit.ly/2eoJrun  

- Create a folder on your Desktop and name it “Google Earth workshop” 

- Copy the data folder to the folder you just created and unzip the files       

Open Google Earth by either: 

- Double clicking on the Google Earth icon on your desktop; or 

- Navigating to > Applications > Google Earth 

Before we start our exercise, we need to create a folder in Google Earth in order to be able to save our 

work.  

- Right-click on “My Places” then add a new folder (Right-click “My Places” > Add > Folder) 

 

http://atlas.gwichin.ca/index.html
http://urbanarium.org/smartmap
http://www.montrealsoundmap.com/
http://bit.ly/2eoJrun
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- A new window will pop-up in which you can name your new folder. Name it “Historical 

streams”. 

- Now we will being adding spatial data to this folder. From your working folder Please double-

click on the “OldStreamsPolylineGoogleEarth.kmz” file. This a dataset of Vancouver’s historical 

streams and shoreline.  

- Upon clicking, Google Earth will take you to Vancouver and show the old streams and former 

shoreline of the city as a layer. 

- Now, drag and drop the old stream dataset into the folder you created in My Places.  

- Locate the salmon stream described in the poem and then right-click on it and change its colour 

to something that stands out more. [If you want to change the colour of the entire dataset, 

right-click on it in the Table of Contents and then click Properties > Style, color, > Share style and 

then click on the colour box.] 

  
 

- Now we will add some georectified images from the City of Vancouver Open Data Catalogue. 

These images have already been provided to you in your working folder. There are 4 images that 

cover the area discussed in the poem from the 1912 Goad’s fire insurance map of Vancouver. 

These images are parts, or tiles, from a larger map.  
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- Please go to Google Earth > File > Open … and navigate to the working folder to find the images. 

The images can be found if you change the file type to “Geo TIFF (*.tif)”. 

 

 

- Now add the images one by one. You will encounter a warning message in Google Earth like this: 

 

 

- Please click on “Scale” for all the images you add to Google Earth. When all four images are 

added, your screen should look like this: 
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- This is a screenshot of the images overlaid with the old streams and the satellite image of the 

city of Vancouver in the background.  

- Create a new folder in My Places and name it 1912 

- Now, please drag and drop these four images to the new folder you created in My Places. Your 

folder should now look like this: 

 



5 

 

- You can turn each layer on and off to explore how that will affect the representation of your 

work. There is a certain order that is needed to make the tiles work together.  

- You can adjust the transparency of the historical map images by right clicking on an image file in 

the folder and choosing “Properties” and then adjusting the transparency slider for each: 

 

 
 

Adding a georectifed map from Map Warper 

- Go to Map Warper (http://mapwarper.net/) and search for “Vancouver” in the title field.  

- Click on Map of Vancouver, 1963 (it should be your third result) 

- Notice that there is also the option to search for maps by location. 

http://mapwarper.net/
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- Click on “Export” and then choose “Download KML file” 

- Open the KML file in Google Earth to add the 1963 map as another layer. 

 

 

 

- Experiment with the different historical layers you have. Do features line up?  

- Notice that because this map is not an image file, we cannot adjust the transparency. 

- Create a new folder named 1963 for this map and drag and drop the file in the folder. 

- At this point, create a “master folder” named “Hartley poem” and drag and drop all of the 

folders into it. See screenshot next page. 
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Now, we will geo-locate points mentioned in the in the poem by adding placemarks to our map. To do 

this, locate an address and then right-click on the Hartley poem folder in My Places > Add > Placemark 

to store it.  

 

 

- Start by adding a point for Skwayoos Campsite, which is mentioned in the poem and is where 

Kits Beach Bathhouse has come to stand. 

- You can name your points as you see fit and set the colour, scale, and opacity of your points and 

their labels by clicking on the “Style, Color” tab. See screenshots next page.  
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- Choose a placemarker style by clicking on the thumbtack in the popup window. 

- Set the colour and size of the placemarkers and labels by clicking on the shape you want and 

then clicking on “Colour” and “Scale” and “Opacity”. 

- Notice there is also the option to add custom icons. 
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Adding historical photos and other types of data to your points 

- We can add lines from the poem, links, images, and other information in the Description field of 

your points.  

- Go to the Vancouver Archives website (http://searcharchives.vancouver.ca/) 

- Click on Advanced search under the search box at the top of the screen. Once on the Advanced 

search screen, type “view of Kitsilano beach” 1905 [be sure to use the quotation marks] and set 

the search to Title: 

 

- Click on the first result, a photo from July 1, 1905 with the title “View of Kitsilano Beach”: 

 

 

 

- Click on the photograph so you can view the JPG full size. Copy the link to the JPG and paste the 

link in the “Add image” field in the “Description” field of the Kits Beach bathhouse/Skwayoos 

campsite point that we have created and click “OK”. You will need to resize the image by editing the 

HTML code so that it is as follows:  

<img src="http://searcharchives.vancouver.ca/uploads/r/null/8/7/870732/7eb4bec7-5898-4099-

8dd1-9ceb705afc8e-A23645.jpg" width="800"/> 

http://searcharchives.vancouver.ca/
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- Add the line from the poem about the point if you like. (See screen shots below.)  

- Add source/citation information. 

 

 

- Carry on adding points to your map, and information of your choice in the Description fields.  
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Sources of historical photos and other historical information: 

Vancouver Archives (http://searcharchives.vancouver.ca) 

Vancouver Public Library’s Historical Photos of BC and Yukon 

(http://www.vpl.ca/find/details/historical_photographs_of_bc_and_yukon)  

The Commons on Flickr (https://www.flickr.com/commons) 

British Columbia City Directories, 1860-1955 (http://www.vpl.ca/bccd/index.php) 

Historical atlases and newspapers at the Library 

Novels, poetry, nonfiction books.  

Suggested keywords to get you started: 

“Greer’s Beach”, “Kitsilano fill”, Snauq, Khahtsahlano,”Kitsilano Indian Reserve”, CPR, “Canadian Pacific” 

Other datasets may be of interest: 

Downtown Historic Railway. Vancouver Open Data Catalogue. 

http://data.vancouver.ca/datacatalogue/downtownHistoricRailway.htm 

Building footprints, 2009. Vancouver Open Data Catalogue. 

http://data.vancouver.ca/datacatalogue/buildingFootprints.htm  

Goad’s Fire Insurance Map 1912 (georectified). Vancouver Open Data Catalogue. 

http://data.vancouver.ca/datacatalogue/goadsFireInsuranceMap1912.htm  

Railway. City of Vancouver Open Data Catalogue. http://data.vancouver.ca/datacatalogue/railway.htm  

Adding lines and polygons 

- You can also add lines and polygons (shapes) if you’d like: 

 

http://searcharchives.vancouver.ca/
http://www.vpl.ca/find/details/historical_photographs_of_bc_and_yukon
https://www.flickr.com/commons
http://www.vpl.ca/bccd/index.php
http://data.vancouver.ca/datacatalogue/downtownHistoricRailway.htm
http://data.vancouver.ca/datacatalogue/buildingFootprints.htm
http://data.vancouver.ca/datacatalogue/goadsFireInsuranceMap1912.htm
http://data.vancouver.ca/datacatalogue/railway.htm
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Saving and sharing your work 

- When all the locations are pinned, you can save and export your work as a .kmz file. This file can then 

be opened on any computer that has Google Earth Pro installed on it. 

- To save your work, right-click on the master folder (“Hartley poem”) > Save Place As… > kmz  to save 

a .kmz file of your entire folder that makes up your map. This file can then be emailed or uploaded on a 

website so that other users can view your map in Google Earth Pro. Providing a link to the page where 

Google Earth Pro can be downloaded is a nice touch. Google Earth Pro may be downloaded free of 

charge from this page: http://www.google.ca/earth/download/gep/agree.html.  

- Save the map (or various views of the same interactive map) as an image/images (.jpg). The Save 

Image option in the toolbar gives you options for designing the map, including adding a title and legend. 

You are also given a number of options for the resolution that you want to save your image(s) in. The 

Print option in the toolbar offers the same design options.  

- The Email option in the toolbar lets you send a screenshot of the current view or a .kml file of either 

the current view of your map or the entire map (with all the layers in a folder) that will open in Google 

Earth Pro. 

- The Print option in the toolbar lets you print the current view of your map (with the title and legend).  

- Embedding the interactive map into a website without doing a ton of coding is a bit tricky, as Google 

has depreciated the plug-in that enabled easy 

embedding: http://googlegeodevelopers.blogspot.com.au/2014/12/announcing-deprecation-of-google-

earth.html. There has been some effort to re-create the depreciated gadget: http://google-earth-

plugin.blogspot.ca/p/blogger-kml-embed-gadget.html. If using WordPress only, it looks like there are a 

few plug-ins that allow you to embed KML files/Google 

Map: https://wordpress.org/plugins/search.php?q=kml. This is something we are continuing to monitor. 

About the data used in this workshop 

All of the data is open data, so there are no issues with sharing and using however you may desire. The 

historic streams and shoreline data came from the public section of 

Abacus: http://dvn.library.ubc.ca/dvn/dv/ABACUSPD.  

Lesack, Paul; Proctor, Sharon J., 2011-03-23, "Vancouver's Old Streams, 1880-1920", 

http://hdl.handle.net/11272/IKHNQ  

Goad’s Fire Insurance Map 1912 (georectified). Vancouver Open Data Catalogue. 

http://data.vancouver.ca/datacatalogue/goadsFireInsuranceMap1912.htm  

 

Remember to cite any datasets and photos you use in creating a map. Data and images should be cited 

like other documents are and included in the References section of your document.  

 

Please do not hesitate to get in touch if you have questions. 
Julie Jones, GIS & Map Librarian and Librarian for Geography, julie_jones@sfu.ca 

http://www.google.ca/earth/download/gep/agree.html
http://googlegeodevelopers.blogspot.com.au/2014/12/announcing-deprecation-of-google-earth.html
http://googlegeodevelopers.blogspot.com.au/2014/12/announcing-deprecation-of-google-earth.html
http://google-earth-plugin.blogspot.ca/p/blogger-kml-embed-gadget.html
http://google-earth-plugin.blogspot.ca/p/blogger-kml-embed-gadget.html
https://wordpress.org/plugins/search.php?q=kml
http://dvn.library.ubc.ca/dvn/dv/ABACUSPD
http://hdl.handle.net/11272/IKHNQ
http://data.vancouver.ca/datacatalogue/goadsFireInsuranceMap1912.htm

